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Software and Software Documentation Downloads
The THEMIS Software Web Page URL is http://themis.ssl.berkeley.edu/software.shtml/.  The user can download released 
software and software documentation from this site. NOTE: The user can choose to download not yet released software 
(under ‘Future Releases:’), but it is not recommended . While this software contains updates, enhancements, and bug fixes, 
full quality assurance testing has not been done. Use at your own risk. 

System Requirements
The THEMIS Data Analysis Software requires an IDL developer’s license for Windows or a UNIX-like operating system, 
e.g. Solaris, Linux, or Mac OS X.  The software has been tested on IDL 6.3, 6.4, 7.0, 7.1, 8.3.  There are some minor issues 
running TDAS with IDL version 8.0 and above: font sizes may be different (so that plots produced with the default options 
may have overlapping labels). 

Installation with a full IDL development license
   For a new installation:

1. Download and expand the latest SPEDAS release .zip file.  
2. Create a directory called SPEDAS into which you will copy the latest software.
3. Move the spedas_x_xx folder into the SPEDAS directory you created.
4. Configure IDL to search the SPEDAS directory for IDL programs.  See section1.3.1:IDL PATH setup of the TDAS 

user's guide. 

For an upgrade of an existing installation of TDAS, as per the above 4 steps:
1. Remove old tdas_x_xx or spedas_x_xx from the SPEDAS (or TDAS)  directory.
2. Download and expand the latest SPEDAS release .zip file.
3. Copy the new spedas_x_xx directory into the pre-existing SPEDAS directory.
4. Re-start IDL.

Installation without an IDL license
1. Download a full version of IDL from Exelis, www.exelisvis.com
2. Download the virtual machine release of SPEDAS from the Software section of the THEMIS website, 

http://themis.ssl.berkeley.edu/software.shtml
3. Extract the SPEDAS-VM release to a folder on your local machine
4. Start the IDL virtual machine and click the splash screen
5. Navigate to the folder where you extracted the SPEDAS-VM release and select the file spd_gui.sav

Installation of executable files, for 64-bit systems
1. Download an executable release of SPEDAS from the Software section of the THEMIS website, 

http://themis.ssl.berkeley.edu/software.shtml
2. Extract the SPEDAS release to a folder on your local machine
3. Navigate to the folder where you extracted the SPEDAS release and run the file spd_gui/spedas 

CDF File Formats
It is important to note that there is a patch to IDL which is necessary for the proper handling of the CDF file format that is 
used by the THEMIS data files. Problems ranging from crashes to corrupted data to memory leaks can result if patch is not 
made. See:  http://cdf.gsfc.nasa.gov/html/cdf_patch_for_idl6x_new3400.html  .   If you are using IDL 6.2, Intel Mac with any 
version of IDL, or IDL 7.0/7.1 you must install this patch to read CDF files properly.   Special note for Mac: If there are 
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problems with the files you downloaded from GSFC, please download them from the THEMIS ftp site 
http://themis-tmserver1.ssl.berkeley.edu/~themis/public_share/idl_mac/.

Mac OS X Notes
You need X11 (on newer Macs, the package is called Xquartz, and is not installed by default) to view plots and use the GUI 
in IDL.  You can search for X11 in the Spotlight to see if the X11 application is installed on your system.  X11 is available on 
your Mac installation disks, but may not be installed by default. 

Note that X11 must be running, not just installed to properly view IDL plots.

There is a known problem, mentioned in the IDL 6.3 release notes, which affects all IDL users running Mac OS 10.4.x
 (Tiger) or MacOS 10.5.x (Leopard). The tlimit command will lock up IDL because the plot window will not receive any 
mouse clicks.  

Workaround: Change the X11 start-up parameters. Do the following:
1. Open any terminal window (in X11 application menu bar, choose xterm from the applications menu)
2. Click on Apple->"About This Mac", and check your Mac OS X version.  
3. Enter one of the following commands at the shell prompt in the terminal window, depending on which Mac OS 

X version you have:
4. Mac OS X 10.4.x users:  defaults write com.apple.x11 wm_click_through -bool true 
5. Mac OS X 10.5.x users:  defaults write org.x.x11 wm_click_through -bool true 
6. Quit X11 (if it is running).

The new default will take effect the next time you start X11, and it will persist from that point (i.e., you will not have to make 
the change again).
If you continue to have trouble with mouse clicks, you may need to set “Emulate three button mouse” in X11 (go to X11-> 
Preferences->Input).

Linux Notes
There are problems with some versions of Ubuntu and IDL graphic objects. If you find that widgets are not realized when 
opening a new window, you may need to turn visual effects off. This can be done using ubuntu system preferences and setting 
Visual effects to none.  

IDL Setup (Unix, Linux or Mac OS X)
Path:  For Windows or IDLDE on UNIX, you can use the File->Preferences widget to set up the path so IDL can find the 
THEMIS IDL files.  For additional details on how to do this please see section 1.3, Installation and Configuration of the 
Software User’s Guide. Note: On IDL 7.0 or later use Window->Preferences, then IDL->Paths on IDL 7.0.
Command Line: For the command line version of IDL, installation consists of setting up the IDL_PATH environment 
variable. For additional details on how to do this please see section 1.3, Installation and Configuration of the Software User’s 
Guide.
The most common problem people have is with an improperly configured path.

Data Directory Setup
SPEDAS requires a local data directory in which data files can be cached.  Each plugin may specify its own local data 
directory in its “Configuration Settings” tab.  If you are using the software for the first time, the local data directory
will default to a directory named something like “data/plugin_name” under your home directory.  Be aware that this directory 
will grow over time, so you may want to change this setting in each Configuration Settings tab to something more 
appropriate, like an external drive or a network share. 
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Known Limitations
1. Incompatibilities with Solar Software (SSW).  Some names clash if both TDAS and SSW are on your  IDL_PATH.
2. ASI data: ASF (full resolution ASI data) requires a 64-bit machine to load more than 1 hour’s worth of data.
3. The IDL executive command .reset_session does not work for the THEMIS GUI software. Please use the                           

command .full_reset_session to reset IDL sessions
4. If any command line procedure has an IDL stop or suspend within it, other code such as the GUI will stop until the user 

continues. Likewise, when the GUI has a modal panel up the themis or idl command line will not execute until the 
window is dismissed.

5. The TDAS software is based on “tplot”, which is a suite of IDL programs developed in the 1990’s and extensively used 
by other missions, such as FAST, WIND, CLUSTER, and STEREO/IMPACT. It is possible that users may have older 
copies of the tplot software in the IDL path, from other  missions.    We recommend that you only keep the TDAS 
version of  the tplot software in your IDL path; this is the only version that is currently supported. 

       See section 1.3. Installation and Configuration of the Software User’s Guide for information on IDL path setup. It is  
       possible to find if there are multiple versions of tplot in your IDL path using the TDAS routine “libs”, for example:

IDL> libs, ‘tplot’
   should return something that looks like this:

C:\idlpro\spedas_1_00\idl\general\tplot\tplot.pro

   If more than one entry is returned, then the non-TDAS tplot directory should be removed from your IDL path.     
       If this causes a problem with older software, then please contact the THEMIS software team, and we will 
       find and attempt to fix the problem. 

Getting Help 
Web Page: From either the Software or Contact Us Web Pages the user can send comments, observations, problems or 
questions about data access, software or web site content. A help request form is available for your use. 
GUI: By clicking on the “HELP" drop down menu on the GUI Main window or if the THEMIS Science Software GUI 
detects an error, a Help Request Form will be displayed. When you click ‘Save’, the error report form and history file will be 
saved. Please email error report forms, history files, or other information to the THEMIS_Science_Support@ssl.berkeley.edu  .  
Cribs: The TDAS software includes numerous examples with common use examples for our routines.  Examples for TPLOT 
and general purpose plotting are in the directory ssl_general/examples/ of the TDAS distribution.  Examples for THEMIS are 
in the directory themis/examples/ of the TDAS distribution.

Graphical User Interface
To start the THEMIS GUI the user needs to start up IDL.
At the IDL command line type:    idl> spd_gui
Once the main GUI window is open the user can select from several pull down menus and/or toolbar buttons.
To Load Data: From the File pull-down menu, select Load THEMIS Data or select the toolbar button Load Data.
To Plot Data:  From the Graph pull down menu, select Plot/Layout Options.
To Print: From the File pull-down menu, select Export Image to File. Select encapsulated post script. Print resolution can be 
increased to publication quality by clicking the ‘Options’ button. 

Common Problems:

Common Problem #1 
"I get an error similar to:
% Attempt to call undefined procedure/function: 'THM_FUNCTION''.
% Execution halted at: $MAIN$ "

Solution:
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9 times out of 10 this is because of a problem with the configuration of your IDL path.  IDL is fairly finicky about the way it 
needs to be told where files are.  

What solution is best depends on your IDL version.

IDLDE 7.0/7.1:
a) Open the window->preferences menu.
b) Select IDL->Paths
c) Select Insert.
d) Select the top level directory in which you installed TDAS, and select Ok
e) Check the box next to the left of the newly created directory and select Ok.
f) Type .full_reset_session at the idl command line.

IDLDE 6.4 or earlier:
a) Open the file->preferences menu.
b) Select Paths
c) Select Insert.
d) Select the top level directory in which you installed TDAS, and select Ok
e) Check the box next to the left of the newly created directory and select Ok.
f) Type .full_reset_session at the idl command line.

IDL command line(all versions):
  You need to configure the IDL_PATH environment variable with the location of the installed files.  Depending on your 
OS/command line environment there are many different ways to do it.  In all cases, it is very important to remember to put a 
'+' before the directory name.  This tells IDL to search the subdirectories recursively.  Below are solutions for common 
environments.

  Bash:
a) Put the following line into you .bashrc or .bash_profile:
export IDL_PATH=’<IDL_DEFAULT>:+/path/to/tdas’
b) Replace /path/to/tdas with your actual installation directory.
c) Restart your shell/terminal or source your .bashrc/.bash_profile to be sure that changes took effect.
d) Restart IDL

  CSH/TCSH:
a) Put the following line into you .cshrc:
setenv IDL_PATH ’<IDL_DEFAULT>:+/path/to/tdas’
b) Replace /path/to/tdas with your actual installation directory.
c) Restart your shell/terminal or source your .bashrc/.bash_profile to be sure that changes took effect.
d) Restart IDL

Common Problem #2:
"I made a change in a program and the changes don't take effect" or
"I put a new version of a program I got from a colleague in my work space and IDL finds the old one" or
"I reinstalled a new version of TDAS that is supposed to fix my problem, but it still doesn't work."

Solution:
IDL keeps copies of compiled programs in memory to improve performance.  The downside to this is that is doesn't always 
update these copies when you change a program on the disk.  
a) If your change is only in a single program, you should always recompile that program after making a change.  You can do 
this using the command .compile program_name.  Where "program_name" is the name of the program you changed.
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b) If your change is in multiple programs (like a new version of TDAS), the best solution is to reset your session by typing 
the  .full_reset_session command.  Be warned, however, any work you have in your current session will be deleted.   You 
should always save your work before a .full_reset_session.
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